Перейти к содержимому


Установка на Linux сервер

Linux сервер

Сообщений в теме: 4

#1 Andrew

    Новичок

  • Пользователи
  • Pip
  • 1 сообщений

Отправлено 04 Март 2017 - 13:16

Доброго всем дня, хочется обратится к разрабам или людям которые знают и понимают ..... подскажите как правильно установить данное ПО на линукс сервере те крохи информации которые есть не совсем помогают ... ((( информации как таковой мало ... в идеале хотелось бы пошаговую инструкцию ... хотя понимаю что это мало вероятно ..
за ранее спасибо

#2 AntonKravchenko

    Активный участник

  • Пользователи
  • PipPipPip
  • 137 сообщений
  • Пол:Мужчина
  • Город:Нижний Новгород

Отправлено 06 Март 2017 - 10:36

· Обновление системы «yum update»

· Установить параметр SELinux в «disabled», перезагрузить

· Установка webmin (мне с ним проще), http://www.webmin.com/rpm.html

· Отключить файрволл «service iptables stop» (я не знаю другого способа разрешить порт 10000 для webmin)

· Установка компонентов «yum install wget httpd php php-common php-pear-Net-Curl php-gd php-imap php-mcrypt php-mbstring mysql unzip» с https://clientbase.r...entskoj_ba/#rpm

· Установка MySQL сервера «yum –y install mysqld», настройка параметров (можно взять из нынешнего конфига)

· Установка компонента php-mysql «yum –y install php-mysql»

· Проверка списка установленных PHP-модулей командой «php -m», сравнить список с https://clientbase.r...aniya/#modules. Если чего-то не хватает, доустановить командой «yum –y install php-XXX», где вместо ХХХ указать название модуля. Я доустанавливал imap, mcrypt и что-то ещё. Если командой не ставится, гуглить, как ставить. Иногда нужно подключать какие-то репозитории и т.п.

· Настройка параметров PHP под требования https://clientbase.r...rebovaniya/#php + перезапуск apache

· Установка ZendOptimizer (он же ZendGuardLoader) с http://www.zend.com/...downloads#Linux + перезапуск apache. Я ещё поставил ZendOpCache. Как оказалось впоследствии, очень не зря

· Проверить, что Zend установился. Команда «php -m». Можно взять из нынешнего конфига все настройки

· На всякий случай перезапуск Apache и MySQL сервера

· В папку var/www/html скачать и распаковать архив с https://clientbase.ru/download/ под соответствующую версию PHP (узнать командой «php –v»)

· на MySQL сервере создать новую базу с кодировкой UTF-8 и вторым параметром UTF-8_general_ci

· перейти в браузере на адрес СЕРВЕР/cb

· загрузится окно первичной настройки КБ, указать название базы, пароль и логин подключения к ней (root без пароля по умолчанию), и тип установки – можно либо стандартную, либо нулевую конфигурацию

· на следующем шаге ввести данные для настройки главного администратора КБ

· дождаться завершения установки

· перейти в шестерёнку – Дополнительно – Проверка системы. Убедиться, что ошибок нет. Если есть, исправить. Если ошибки есть, то чаще всего это нехватка PHP модулей или заниженные параметры MySQL сервера. Погуглить оптимальные значения, исправить (или взять конфиги из нынешней настройки)

· выполнить донастройку apache по этому http://valerij.pp.ua/apache-static/

· выполнить донастройку ZendOpCache (не помню, откуда взял, можно взять из нынешнего конфига)

· перезапуск всего

#3 Tony999

    Активный участник

  • Пользователи
  • PipPipPip
  • 395 сообщений
  • Пол:Мужчина
  • Город:Санкт-Петербург

Отправлено 08 Март 2017 - 02:30

... еще бы присоветовал PHP не ниже версии 5.4 использовать, а также IonCube вместо ZendOptimizer (быстрее работает).
Как поставить - все это легко гуглится.
КБ - помощь, проекты и решения.
Хостинг. Аренда. Продажа.
ВашаБаза.рф

#4 master2015

    Активный участник

  • Пользователи
  • PipPipPip
  • 35 сообщений
  • Пол:Мужчина
  • Интересы:Программирование

Отправлено 10 Март 2017 - 20:59

Просмотр сообщенияTony999 (08 Март 2017 - 02:30) писал:

... еще бы присоветовал PHP не ниже версии 5.4 использовать, а также IonCube вместо ZendOptimizer (быстрее работает).
Как поставить - все это легко гуглится.

Tony, а почему именно не ниже версии 5.4? (ну кроме возможности использования API). У нас сейчас стоит версия 5.3.3, какие то еще преимущества на ваш взгляд есть?

#5 Tony999

    Активный участник

  • Пользователи
  • PipPipPip
  • 395 сообщений
  • Пол:Мужчина
  • Город:Санкт-Петербург

Отправлено 13 Март 2017 - 14:18

... это если какие-либо "примочки" ставить будете, может не работать... уж больно старая версия 5.3., тем более поставить новее особых проблем нет.
КБ - помощь, проекты и решения.
Хостинг. Аренда. Продажа.
ВашаБаза.рф





Количество пользователей, читающих эту тему: 1

0 пользователей, 1 гостей, 0 анонимных